From: Muhammad Rizki <[email protected]>
To: Ammar Faizi <[email protected]>
Cc: Muhammad Rizki <[email protected]>,
Alviro Iskandar Setiawan <[email protected]>,
GNU/Weeb Mailing List <[email protected]>
Subject: [PATCH v1 00/17] Profile Page, SEO, Fixed API structure, Docs
Date: Wed, 5 Mar 2025 21:39:59 +0700 [thread overview]
Message-ID: <[email protected]> (raw)
Hello,
This series of patches was planned only to update profile page feature,
since there is a change in the API structure, I also fixed
the API response type to prevent breaking change.
To prevent more breaking change on production site in the future,
sir Ammar has made a staging API for development stage,
since there is a staging API version, I added an environment variable
`PUBLIC_BASE_URL` for each environment (development or production).
You should set `PUBLIC_BASE_URL` environment in your own server,
there is an example file for development and production environment
in this patch, please see `.env.development.example` and
`.env.production.example` in root directory.
I also added API documentation in Postman workspace that I created
myself, you can find it in this link:
https://gnuweeb.postman.co/workspace/GNU%252FWeeb~2805fbdd-376b-42de-8fe1-2a4cfa22ed3c/overview?ctx=updates
Please give it a test and review, thank you.
Muhammad Rizki (17):
fix(typing): add user_info type prop
refactor: optimize icon imports to reduce bundle size
chore(change-pwd): adjust change password heading styling
chore(settings/layout): use prose: for heading styling
fix(profile): fix edit avatar button position
fix(breadcrumb): Move settingsNav to settings items navigations
chore(responsive): adjust styling
chore(navigations): Replace index /settings url
feat(ui): Add popover and dialog UI component
feat(http): Use PUBLIC_BASE_URL for each environment
feat(icons): Add social icons
feat(typing/enum): add Gender and IsActive enum
refactor!:feat: update API response structure, update profile page
chore(meta): rename favicon.png to favicon.ico
feat(seo): add SEO for site metadata
chore(login): use $derived() instead of function based
docs: update README.md
.env.development.example | 2 +
.env.production.example | 2 +
.gitignore | 2 +-
README.md | 7 +
package-lock.json | 8 +-
package.json | 2 +-
src/app.html | 2 +-
src/lib/components/customs/app-sidebar.svelte | 4 +-
src/lib/components/customs/header.svelte | 39 +-
src/lib/components/customs/seo.svelte | 27 +
src/lib/components/icons/icon-discord.svelte | 35 ++
src/lib/components/icons/icon-github.svelte | 35 ++
src/lib/components/icons/icon-telegram.svelte | 35 ++
src/lib/components/icons/icon-twitter.svelte | 35 ++
.../components/ui/avatar/avatar-image.svelte | 2 +-
src/lib/components/ui/avatar/avatar.svelte | 2 +-
.../ui/dialog/dialog-content.svelte | 38 ++
.../ui/dialog/dialog-description.svelte | 16 +
.../components/ui/dialog/dialog-footer.svelte | 20 +
.../components/ui/dialog/dialog-header.svelte | 20 +
.../ui/dialog/dialog-overlay.svelte | 19 +
.../components/ui/dialog/dialog-title.svelte | 16 +
src/lib/components/ui/dialog/index.ts | 37 ++
.../components/ui/input/input-password.svelte | 5 +-
src/lib/components/ui/input/input.svelte | 2 +-
src/lib/components/ui/popover/index.ts | 17 +
.../ui/popover/popover-content.svelte | 28 +
src/lib/constants/navigations.ts | 30 +-
src/lib/hooks/auth.svelte.ts | 12 +-
src/lib/hooks/http.svelte.ts | 3 +-
src/lib/schemas/profile-schema.ts | 20 +-
src/lib/typings/common.d.ts | 11 +
src/lib/typings/credential.d.ts | 11 +-
src/lib/typings/http.d.ts | 11 +-
src/lib/typings/index.ts | 11 +-
src/lib/utilities/index.ts | 3 +-
src/lib/utilities/navigation.ts | 5 +
src/routes/(protected)/+layout.svelte | 12 +
src/routes/(protected)/+layout.ts | 9 +-
.../(components)/settings-header.svelte | 3 +-
.../(protected)/settings/+layout.svelte | 7 +-
src/routes/(protected)/settings/+page.ts | 6 +-
.../(protected)/settings/account/+page.svelte | 9 +-
.../(protected)/settings/profile/+page.svelte | 580 +++++++++++++-----
.../(protected)/settings/profile/+page.ts | 7 +-
src/routes/+page.svelte | 36 +-
static/{favicon.png => favicon.ico} | Bin
47 files changed, 1024 insertions(+), 219 deletions(-)
create mode 100644 .env.development.example
create mode 100644 .env.production.example
create mode 100644 src/lib/components/customs/seo.svelte
create mode 100644 src/lib/components/icons/icon-discord.svelte
create mode 100644 src/lib/components/icons/icon-github.svelte
create mode 100644 src/lib/components/icons/icon-telegram.svelte
create mode 100644 src/lib/components/icons/icon-twitter.svelte
create mode 100644 src/lib/components/ui/dialog/dialog-content.svelte
create mode 100644 src/lib/components/ui/dialog/dialog-description.svelte
create mode 100644 src/lib/components/ui/dialog/dialog-footer.svelte
create mode 100644 src/lib/components/ui/dialog/dialog-header.svelte
create mode 100644 src/lib/components/ui/dialog/dialog-overlay.svelte
create mode 100644 src/lib/components/ui/dialog/dialog-title.svelte
create mode 100644 src/lib/components/ui/dialog/index.ts
create mode 100644 src/lib/components/ui/popover/index.ts
create mode 100644 src/lib/components/ui/popover/popover-content.svelte
create mode 100644 src/lib/utilities/navigation.ts
rename static/{favicon.png => favicon.ico} (100%)
base-commit: 3c3c00ff4e261aaeab8d91323b99eebf22adc4dd
--
Muhammad Rizki
next reply other threads:[~2025-03-05 14:40 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-05 14:39 Muhammad Rizki [this message]
2025-03-05 14:40 ` [PATCH v1 01/17] fix(typing): add user_info type prop Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 02/17] refactor: optimize icon imports to reduce bundle size Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 03/17] chore(change-pwd): adjust change password heading styling Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 04/17] chore(settings/layout): use prose: for " Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 05/17] fix(profile): fix edit avatar button position Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 06/17] fix(breadcrumb): Move settingsNav to settings items navigations Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 07/17] chore(responsive): adjust styling Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 08/17] chore(navigations): Replace index /settings url Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 09/17] feat(ui): Add popover and dialog UI component Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 10/17] feat(http): Use PUBLIC_BASE_URL for each environment Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 11/17] feat(icons): Add social icons Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 12/17] feat(typing/enum): add Gender and IsActive enum Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 13/17] refactor!:feat: update API response structure, update profile page Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 14/17] chore(meta): rename favicon.png to favicon.ico Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 15/17] feat(seo): add SEO for site metadata Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 16/17] chore(login): use $derived() instead of function based Muhammad Rizki
2025-03-05 14:40 ` [PATCH v1 17/17] docs: update README.md Muhammad Rizki
2025-03-05 16:54 ` [PATCH v1 00/17] Profile Page, SEO, Fixed API structure, Docs Ammar Faizi
2025-03-05 16:57 ` Alviro Iskandar Setiawan
2025-03-06 7:01 ` Muhammad Rizki
2025-03-06 7:02 ` Alviro Iskandar Setiawan
2025-03-06 7:04 ` Muhammad Rizki
2025-03-06 2:02 ` Muhammad Rizki
2025-03-06 3:37 ` Ammar Faizi
2025-03-05 17:04 ` Ammar Faizi
2025-03-05 18:14 ` Alviro Iskandar Setiawan
2025-03-06 1:59 ` Muhammad Rizki
2025-03-06 3:35 ` Ammar Faizi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox