public inbox for [email protected]
 help / color / mirror / Atom feed
From: Breno Leitao <[email protected]>
To: [email protected], [email protected],
	[email protected], [email protected], [email protected]
Cc: [email protected], [email protected],
	[email protected], [email protected],
	[email protected], [email protected], [email protected]
Subject: [PATCH v3 0/4] io_uring: Pass the whole sqe to commands
Date: Sun, 30 Apr 2023 07:35:28 -0700	[thread overview]
Message-ID: <[email protected]> (raw)

These three patches prepare for the sock support in the io_uring cmd, as
described in the following RFC:

	https://lore.kernel.org/lkml/[email protected]/

Since the support linked above depends on other refactors, such as the sock
ioctl() sock refactor[1], I would like to start integrating patches that have
consensus and can bring value right now.  This will also reduce the patchset
size later.

Regarding to these three patches, they are simple changes that turn
io_uring cmd subsystem more flexible (by passing the whole SQE to the
command), and cleaning up an unnecessary compile check.

These patches were tested by creating a file system and mounting an NVME disk
using ubdsrv/ublkb0.

[1] [email protected]/">https://lore.kernel.org/lkml/[email protected]/

Reviewed-by: Kanchan Joshi <[email protected]>

V1 -> V2 :
  * Create a helper to return the size of the SQE
V2 -> V3:
  * Transformed uring_sqe_size() into a proper function
  * Fixed some commit messages
  * Created a helper function for nvme/host to avoid casting
  * Added a fourth patch to avoid ublk_drv's casts by using a proper helper

Breno Leitao (4):
  io_uring: Create a helper to return the SQE size
  io_uring: Pass whole sqe to commands
  io_uring: Remove unnecessary BUILD_BUG_ON
  block: ublk_drv: Add a helper instead of casting

 drivers/block/ublk_drv.c  | 36 ++++++++++++++++++++++++------------
 drivers/nvme/host/ioctl.c |  8 +++++++-
 include/linux/io_uring.h  |  2 +-
 io_uring/io_uring.h       | 10 ++++++++++
 io_uring/opdef.c          |  2 +-
 io_uring/uring_cmd.c      | 13 ++++---------
 io_uring/uring_cmd.h      |  8 --------
 7 files changed, 47 insertions(+), 32 deletions(-)

-- 
2.34.1


             reply	other threads:[~2023-04-30 14:36 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-04-30 14:35 Breno Leitao [this message]
2023-04-30 14:35 ` [PATCH v3 1/4] io_uring: Create a helper to return the SQE size Breno Leitao
2023-05-01  4:28   ` Christoph Hellwig
2023-04-30 14:35 ` [PATCH v3 2/4] io_uring: Pass whole sqe to commands Breno Leitao
2023-05-01  4:30   ` Christoph Hellwig
2023-04-30 14:35 ` [PATCH v3 3/4] io_uring: Remove unnecessary BUILD_BUG_ON Breno Leitao
2023-04-30 14:35 ` [PATCH v3 4/4] block: ublk_drv: Add a helper instead of casting Breno Leitao
2023-05-01  4:31   ` Christoph Hellwig
2023-05-03 19:11     ` Breno Leitao

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    [email protected] \
    [email protected] \
    [email protected] \
    [email protected] \
    [email protected] \
    [email protected] \
    [email protected] \
    [email protected] \
    [email protected] \
    [email protected] \
    [email protected] \
    [email protected] \
    [email protected] \
    [email protected] \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox