From: Pavel Begunkov <[email protected]>
To: Olivier Langlois <[email protected]>,
Jens Axboe <[email protected]>,
[email protected], [email protected]
Subject: Re: [PATCH v2] io_uring: reduce latency by reissueing the operation
Date: Sun, 20 Jun 2021 22:09:12 +0100 [thread overview]
Message-ID: <[email protected]> (raw)
In-Reply-To: <[email protected]>
On 6/20/21 10:05 PM, Olivier Langlois wrote:
> On Sun, 2021-06-20 at 20:56 +0100, Pavel Begunkov wrote:
>> On 6/20/21 8:05 PM, Olivier Langlois wrote:
>>>
>>>
>>> -static bool io_arm_poll_handler(struct io_kiocb *req)
>>> +#define IO_ARM_POLL_OK 0
>>> +#define IO_ARM_POLL_ERR 1
>>> +#define IO_ARM_POLL_READY 2
>>
>> Please add a new line here. Can even be moved somewhere
>> to the top, but it's a matter of taste.
>
> If you let me decide, I prefer to let them close to where they are
> used. There is so much data definitions in the heading section that I
> feel like putting very minor implementation details to it might
> overwhelm newcomers instead of helping them to grasp the big picture.
Oh yeah, I think any is fine. And there are others
happily living in this style, like FFS_ASYNC_READ
> but I will add an extra space as you request
>>
>> Also, how about to rename it to apoll? io_uring internal
>> rw/send/recv polling is often abbreviated as such around
>> io_uring.c
>> IO_APOLL_OK and so on.
>
> no problem. I will.
>>
>>> +static int io_arm_poll_handler(struct io_kiocb *req)
>>> {
>>> const struct io_op_def *def = &io_op_defs[req->opcode];
>>> struct io_ring_ctx *ctx = req->ctx;
>>> @@ -5153,22 +5156,22 @@ static bool io_arm_poll_handler(struct
>>> io_kiocb *req)
>>> int rw;
>>>
>>> if (!req->file || !file_can_poll(req->file))
>>> - return false;
>>> + return IO_ARM_POLL_ERR;
>>
>> It's not really an error. Maybe IO_APOLL_ABORTED or so?
>
> Ok.
>
>
--
Pavel Begunkov
next prev parent reply other threads:[~2021-06-20 21:09 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-06-20 19:05 [PATCH v2] io_uring: reduce latency by reissueing the operation Olivier Langlois
2021-06-20 19:07 ` Randy Dunlap
2021-06-20 19:28 ` Olivier Langlois
2021-06-20 20:01 ` Randy Dunlap
2021-06-20 20:08 ` Pavel Begunkov
2021-06-20 20:54 ` Olivier Langlois
2021-06-20 22:17 ` Randy Dunlap
2021-06-21 16:03 ` Jens Axboe
2021-06-20 19:56 ` Pavel Begunkov
2021-06-20 20:03 ` Pavel Begunkov
2021-06-20 20:56 ` Olivier Langlois
2021-06-20 21:05 ` Olivier Langlois
2021-06-20 21:09 ` Pavel Begunkov [this message]
2021-06-20 21:11 ` Pavel Begunkov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox