From: Jens Axboe <[email protected]>
To: Ammar Faizi <[email protected]>
Cc: io-uring Mailing List <[email protected]>,
netdev Mailing List <[email protected]>,
GNU/Weeb Mailing List <[email protected]>,
Tea Inside Mailing List <[email protected]>,
Linux Kernel Mailing List <[email protected]>,
Pavel Begunkov <[email protected]>,
"David S. Miller" <[email protected]>,
Jakub Kicinski <[email protected]>, Nugra <[email protected]>,
Praveen Kumar <[email protected]>,
Alviro Iskandar Setiawan <[email protected]>
Subject: Re: [PATCH for-5.18 v1 0/3] Add `sendto(2)` and `recvfrom(2)` support
Date: Sat, 29 Jan 2022 11:32:21 -0700 [thread overview]
Message-ID: <[email protected]> (raw)
In-Reply-To: <[email protected]>
On 1/29/22 5:50 AM, Ammar Faizi wrote:
> Hello,
>
> This patchset adds sendto(2) and recvfrom(2) support for io_uring. It
> also addresses an issue in the liburing GitHub repository [1].
>
> ## Motivations:
>
> 1) By using `sendto()` and `recvfrom()` we can make the submission
> simpler compared to always using `sendmsg()` and `recvmsg()` from
> the userspace. Especially for UDP socket.
>
> 2) There is a historical patch that tried to add the same
> functionality, but did not end up being applied. [2]
As far as I can tell, the only win from sendto/recvfrom is that we can
handle async offload a bit cheaper compared to sendmsg/recvmsg. Is this
enough to warrant adding them separately? I don't know, which is why
this has been somewhat stalled for a while.
Maybe you have done some testing and have numbers (or other reasons) to
back up the submission? There's not a whole lot of justification in this
patchset.
--
Jens Axboe
next prev parent reply other threads:[~2022-01-29 18:32 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-01-29 12:50 [PATCH for-5.18 v1 0/3] Add `sendto(2)` and `recvfrom(2)` support Ammar Faizi
2022-01-29 12:50 ` [PATCH for-5.18 v1 1/3] io_uring: Rename `io_{send,recv}` to `io_{sendto,recvfrom}` Ammar Faizi
2022-01-29 12:50 ` [PATCH for-5.18 v1 2/3] net: Make `move_addr_to_user()` be a non static function Ammar Faizi
2022-01-29 12:50 ` [PATCH for-5.18 v1 3/3] io_uring: Add `sendto(2)` and `recvfrom(2)` support Ammar Faizi
2022-01-29 18:32 ` Jens Axboe [this message]
2022-01-29 23:30 ` [PATCH for-5.18 v1 0/3] " Ammar Faizi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox