From: Matthew Wilcox <[email protected]>
To: Hao Xu <[email protected]>
Cc: [email protected], Jens Axboe <[email protected]>,
Dominique Martinet <[email protected]>,
Pavel Begunkov <[email protected]>,
Christian Brauner <[email protected]>,
Alexander Viro <[email protected]>,
Stefan Roesch <[email protected]>, Clay Harris <[email protected]>,
Dave Chinner <[email protected]>,
"Darrick J . Wong" <[email protected]>,
[email protected], [email protected],
[email protected], [email protected],
[email protected], [email protected],
[email protected], [email protected],
[email protected], [email protected],
[email protected], [email protected],
[email protected], [email protected],
[email protected], [email protected],
[email protected], [email protected],
[email protected], [email protected],
[email protected], [email protected],
Wanpeng Li <[email protected]>
Subject: Re: [PATCH 02/11] xfs: add NOWAIT semantics for readdir
Date: Tue, 29 Aug 2023 14:05:10 +0100 [thread overview]
Message-ID: <[email protected]> (raw)
In-Reply-To: <[email protected]>
On Tue, Aug 29, 2023 at 03:41:43PM +0800, Hao Xu wrote:
> On 8/28/23 04:44, Matthew Wilcox wrote:
> > > @@ -391,10 +401,17 @@ xfs_dir2_leaf_getdents(
> > > bp = NULL;
> > > }
> > > - if (*lock_mode == 0)
> > > - *lock_mode = xfs_ilock_data_map_shared(dp);
> > > + if (*lock_mode == 0) {
> > > + *lock_mode =
> > > + xfs_ilock_data_map_shared_generic(dp,
> > > + ctx->flags & DIR_CONTEXT_F_NOWAIT);
> > > + if (!*lock_mode) {
> > > + error = -EAGAIN;
> > > + break;
> > > + }
> > > + }
> >
> > 'generic' doesn't seem like a great suffix to mean 'takes nowait flag'.
> > And this is far too far indented.
> >
> > xfs_dir2_lock(dp, ctx, lock_mode);
> >
> > with:
> >
> > STATIC void xfs_dir2_lock(struct xfs_inode *dp, struct dir_context *ctx,
> > unsigned int lock_mode)
> > {
> > if (*lock_mode)
> > return;
> > if (ctx->flags & DIR_CONTEXT_F_NOWAIT)
> > return xfs_ilock_data_map_shared_nowait(dp);
> > return xfs_ilock_data_map_shared(dp);
> > }
> >
> > ... which I think you can use elsewhere in this patch (reformat it to
> > XFS coding style, of course). And then you don't need
> > xfs_ilock_data_map_shared_generic().
>
> How about rename xfs_ilock_data_map_shared() to xfs_ilock_data_map_block()
> and rename xfs_ilock_data_map_shared_generic() to
> xfs_ilock_data_map_shared()?
>
> STATIC void xfs_ilock_data_map_shared(struct xfs_inode *dp, struct
> dir_context *ctx, unsigned int lock_mode)
> {
> if (*lock_mode)
> return;
> if (ctx->flags & DIR_CONTEXT_F_NOWAIT)
> return xfs_ilock_data_map_shared_nowait(dp);
> return xfs_ilock_data_map_shared_block(dp);
> }
xfs_ilock_data_map_shared() is used for a lot of things which are not
directories. I think a new function name is appropriate, and that
function name should include the word 'dir' in it somewhere.
next prev parent reply other threads:[~2023-08-29 13:06 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-08-27 13:28 [PATCH v6 00/11] io_uring getdents Hao Xu
2023-08-27 13:28 ` [PATCH 01/11] fs: split off vfs_getdents function of getdents64 syscall Hao Xu
2023-08-27 13:28 ` [PATCH 02/11] xfs: add NOWAIT semantics for readdir Hao Xu
2023-08-27 20:44 ` Matthew Wilcox
2023-08-29 7:41 ` Hao Xu
2023-08-29 13:05 ` Matthew Wilcox [this message]
2023-09-04 1:02 ` Dave Chinner
2023-08-27 13:28 ` [PATCH 03/11] vfs: add nowait flag for struct dir_context Hao Xu
2023-08-27 13:28 ` [PATCH 04/11] vfs: add a vfs helper for io_uring file pos lock Hao Xu
2023-08-27 20:47 ` Matthew Wilcox
2023-08-27 13:28 ` [PATCH 05/11] vfs: add file_pos_unlock() for io_uring usage Hao Xu
2023-08-27 13:28 ` [PATCH 06/11] vfs: add a nowait parameter for touch_atime() Hao Xu
2023-08-27 13:28 ` [PATCH 07/11] vfs: add nowait parameter for file_accessed() Hao Xu
2023-08-27 21:32 ` Matthew Wilcox
2023-08-29 7:46 ` Hao Xu
2023-08-29 11:53 ` Matthew Wilcox
2023-08-30 6:11 ` Hao Xu
2023-09-03 22:30 ` Dave Chinner
2023-09-08 0:29 ` Pavel Begunkov
2023-09-10 22:01 ` Dave Chinner
2023-09-04 9:51 ` Christian Brauner
2023-08-27 13:28 ` [PATCH 08/11] vfs: move file_accessed() to the beginning of iterate_dir() Hao Xu
2023-08-27 13:28 ` [PATCH 09/11] vfs: error out -EAGAIN if atime needs to be updated Hao Xu
2023-08-27 20:51 ` Matthew Wilcox
2023-08-27 13:28 ` [PATCH 10/11] vfs: trylock inode->i_rwsem in iterate_dir() to support nowait Hao Xu
2023-09-04 9:37 ` Christian Brauner
2023-08-27 13:28 ` [PATCH 11/11] io_uring: add support for getdents Hao Xu
2023-09-04 9:57 ` [PATCH v6 00/11] io_uring getdents Christian Brauner
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox