From: Christoph Hellwig <[email protected]>
To: Pavel Begunkov <[email protected]>
Cc: Christoph Hellwig <[email protected]>,
[email protected], Jens Axboe <[email protected]>,
Conrad Meyer <[email protected]>,
[email protected], [email protected],
[email protected]
Subject: Re: [PATCH v2 5/7] block: implement async discard as io_uring cmd
Date: Fri, 23 Aug 2024 04:59:13 -0700 [thread overview]
Message-ID: <[email protected]> (raw)
In-Reply-To: <[email protected]>
On Thu, Aug 22, 2024 at 02:07:16PM +0100, Pavel Begunkov wrote:
> > > Note, unlike ioctl(BLKDISCARD) with stronger guarantees against races,
> > > we only do a best effort attempt to invalidate page cache, and it can
> > > race with any writes and reads and leave page cache stale. It's the
> > > same kind of races we allow to direct writes.
> >
> > Can you please write up a man page for this that clear documents the
> > expecvted semantics?
>
> Do we have it documented anywhere how O_DIRECT writes interact
> with page cache, so I can refer to it?
I can't find a good writeup. Adding Dave as he tends to do long
emails on topic like this so he might have one hiding somewhere.
> > GFP_KERNEL can often will block. You'll probably want a GFP_NOWAIT
> > allocation here for the nowait case.
>
> I can change it for clarity, but I don't think it's much of a concern
> since the read/write path and pretty sure a bunch of other places never
> cared about it. It does the main thing, propagating it down e.g. for
> tag allocation.
True, we're only doing the nowait allocation for larger data
structures. Which is a bit odd indeed.
> I'd rather avoid calling bio_discard_limit() an extra time, it does
> too much stuff inside, when the expected case is a single bio and
> for multi-bio that overhead would really matter.
Compared to a memory allocation it's not really doing all the much.
In the long run we really should move splitting discard bios down
the stack like we do for normal I/O anyway.
> Maybe I should uniline blk_alloc_discard_bio() and dedup it with
uniline? I read that as unіnline, but as it's not inline I don't
understand what you mean either.
> > > +#define BLOCK_URING_CMD_DISCARD 0
> >
> > Is fs.h the reight place for this?
>
> Arguable, but I can move it to io_uring, makes things simpler
> for me.
I would have expected a uapi/linux/blkdev.h for it (and I'm kinda
surprised we don't have that yet).
>
> > Curious: how to we deal with conflicting uring cmds on different
> > device and how do we probe for them? The NVMe uring_cmds
> > use the ioctl-style _IO* encoding which at least helps a bit with
> > that and which seem like a good idea. Maybe someone needs to write
> > up a few lose rules on uring commands?
>
> My concern is that we're sacrificing compiler optimisations
> (well, jump tables are disabled IIRC) for something that doesn't even
> guarantee uniqueness. I'd like to see some degree of reflection,
> like user querying a file class in terms of what operations it
> supports, but that's beyond the scope of the series.
We can't guaranteed uniqueness, but between the class, the direction,
and the argument size we get a pretty good one. There is a reason
pretty much all ioctls added in the last 25 years are using this scheme.
next prev parent reply other threads:[~2024-08-23 11:59 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-08-22 3:35 [PATCH v2 0/7] implement async block discards/etc. via io_uring Pavel Begunkov
2024-08-22 3:35 ` [PATCH v2 1/7] io_uring/cmd: expose iowq to cmds Pavel Begunkov
2024-08-22 3:35 ` [PATCH v2 2/7] io_uring/cmd: give inline space in request " Pavel Begunkov
2024-08-22 3:35 ` [PATCH v2 3/7] filemap: introduce filemap_invalidate_pages Pavel Begunkov
2024-08-22 6:37 ` Christoph Hellwig
2024-08-22 3:35 ` [PATCH v2 4/7] block: introduce blk_validate_write() Pavel Begunkov
2024-08-22 6:33 ` Christoph Hellwig
2024-08-22 12:36 ` Pavel Begunkov
2024-08-23 11:52 ` Christoph Hellwig
2024-08-22 3:35 ` [PATCH v2 5/7] block: implement async discard as io_uring cmd Pavel Begunkov
2024-08-22 6:46 ` Christoph Hellwig
2024-08-22 13:07 ` Pavel Begunkov
2024-08-23 11:59 ` Christoph Hellwig [this message]
2024-09-04 14:08 ` Pavel Begunkov
2024-08-22 3:35 ` [PATCH v2 6/7] block: implement async wire write zeroes Pavel Begunkov
2024-08-22 6:50 ` Christoph Hellwig
2024-08-22 13:09 ` Pavel Begunkov
2024-08-22 3:35 ` [PATCH v2 7/7] block: implement async secure erase Pavel Begunkov
2024-08-22 6:36 ` Christoph Hellwig
2024-08-22 12:36 ` Pavel Begunkov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
[email protected] \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox