* [PATCH V2] io_uring: return void from io_put_kbuf_comp()
@ 2024-04-07 13:27 Ming Lei
2024-04-07 21:49 ` Jens Axboe
0 siblings, 1 reply; 2+ messages in thread
From: Ming Lei @ 2024-04-07 13:27 UTC (permalink / raw)
To: Jens Axboe, io-uring; +Cc: Ming Lei
The only caller doesn't handle the return value of io_put_kbuf_comp(), so
change its return type into void.
Also follow Jen's suggestion to rename it as io_put_kbuf_drop().
Signed-off-by: Ming Lei <[email protected]>
---
V2:
- rename & following check style in kbuf.c(Jens)
io_uring/io_uring.c | 2 +-
io_uring/kbuf.h | 8 ++------
2 files changed, 3 insertions(+), 7 deletions(-)
diff --git a/io_uring/io_uring.c b/io_uring/io_uring.c
index afbe0522e8d8..8df9ad010803 100644
--- a/io_uring/io_uring.c
+++ b/io_uring/io_uring.c
@@ -381,7 +381,7 @@ static void io_clean_op(struct io_kiocb *req)
{
if (req->flags & REQ_F_BUFFER_SELECTED) {
spin_lock(&req->ctx->completion_lock);
- io_put_kbuf_comp(req);
+ io_kbuf_drop(req);
spin_unlock(&req->ctx->completion_lock);
}
diff --git a/io_uring/kbuf.h b/io_uring/kbuf.h
index 53c141d9a8b2..5a9635ee0217 100644
--- a/io_uring/kbuf.h
+++ b/io_uring/kbuf.h
@@ -120,18 +120,14 @@ static inline void __io_put_kbuf_list(struct io_kiocb *req,
}
}
-static inline unsigned int io_put_kbuf_comp(struct io_kiocb *req)
+static inline void io_kbuf_drop(struct io_kiocb *req)
{
- unsigned int ret;
-
lockdep_assert_held(&req->ctx->completion_lock);
if (!(req->flags & (REQ_F_BUFFER_SELECTED|REQ_F_BUFFER_RING)))
- return 0;
+ return;
- ret = IORING_CQE_F_BUFFER | (req->buf_index << IORING_CQE_BUFFER_SHIFT);
__io_put_kbuf_list(req, &req->ctx->io_buffers_comp);
- return ret;
}
static inline unsigned int io_put_kbuf(struct io_kiocb *req,
--
2.41.0
^ permalink raw reply related [flat|nested] 2+ messages in thread
* Re: [PATCH V2] io_uring: return void from io_put_kbuf_comp()
2024-04-07 13:27 [PATCH V2] io_uring: return void from io_put_kbuf_comp() Ming Lei
@ 2024-04-07 21:49 ` Jens Axboe
0 siblings, 0 replies; 2+ messages in thread
From: Jens Axboe @ 2024-04-07 21:49 UTC (permalink / raw)
To: Ming Lei, io-uring
On 4/7/24 7:27 AM, Ming Lei wrote:
> The only caller doesn't handle the return value of io_put_kbuf_comp(), so
> change its return type into void.
>
> Also follow Jen's suggestion to rename it as io_put_kbuf_drop().
Thanks Ming, applied.
--
Jens Axboe
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2024-04-07 21:49 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2024-04-07 13:27 [PATCH V2] io_uring: return void from io_put_kbuf_comp() Ming Lei
2024-04-07 21:49 ` Jens Axboe
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox